How to get SI Bass Guitar & SI String Session working in Cubase

Discussions about VST Instruments and VST plug-ins from other manufacturers
Post Reply
pcbythesea
New Member
Posts: 25
Joined: Fri Nov 30, 2018 3:09 pm
Contact:

How to get SI Bass Guitar & SI String Session working in Cubase

Post by pcbythesea »

This may be useful to ex-Sonar users. These two Cakewalk Studio Instruments came free bundled with Sonar Platinum. They are notorious for not working properly in Cubase. As far as I know there has not been a solution found. Recorded midi clips play back with unwanted sustained notes. However in Cubase Pro 10.5 it is possible to fix this:-

1. Load in SI Bass Guitar or SI String Session.
2. Make sure you have a midi track which outputs to the synth.
3. On this midi track select midi inserts.
4. Select Note to CC.
5. Select CC123 (All Notes Off).
6. Play back recorded midi - should now cut off unwanted sustained notes.

The only thing I found I had to watch out for was for overlapping notes in the midi clip.

glennyg
New Member
Posts: 2
Joined: Sun Nov 30, 2014 5:03 pm
Contact:

Re: How to get SI Bass Guitar & SI String Session working in Cubase

Post by glennyg »

I hit the same problem but came up with a better solution. Monophonic midi is OK for bass but not suitable for strings, drums, piano because you can't play more than one note at a time.

I tried using Transformer but there was no way to identify the note off event and replace it with a Note On with velocity = 0, which is what the Cakewalk plugins need.

Cubase won't record Midi Note vel=0. It converts them into Note Off, which is the problem. Well, really the problem is Cakewalk's plugins not being compliant. According to the midi spec, they should respond to Note Off AND Note On vel=0. Apparently it's easier to code to the vel=0 and they never bothered to make them respond to Note Off.

Bome's Midi Translator Pro can do that! Maybe MidiOx can too, I don't know.

Install Bomes, activate Default Ports Virtual Port 1 in and out. Route the virtual in to the virtual out.
Create this translator:
INCOMING
Midi message : Note Off, any channel, any note, set variable to note pp, any velocity. Swallow.
OUTGOING
Midi message: Note On, Channel 1, Note=pp, Velocity =0 (Bome will alert you that it is outside the range but you can ignore that.)

Create your TRACK instrument (one of the Cakewalk vsti) and set its midi input to Bome Virtual Port 1. Turn on the monitoring (little speaker icon on the track). Create a midi track and set its input to your keyboard and output to Bome Virtual Port 1. Record on the midi track, not the instrument track. The midi data goes out to Bomes, gets transformed and comes back into the instrument track in Cubase. If you record on the instrument track it gets converted to Note Off again and you will have the same issue as before.

Hope that helps.

Post Reply

Return to “VST Instruments and Virtual Effects (general)”

Who is online

Users browsing this forum: No registered users and 1 guest