Page 1 of 1

Elements 7 not working in Win 10

Posted: Wed Nov 04, 2015 3:08 pm
by zipzep
My Wavelab Elements 7 is not working in Windows 10. I have the latest update 7.2.1.600. Is there a way around this? I downloaded the Wavelab Elements 8 trial, and it is working.

Re: Elements 7 not working in Win 10

Posted: Mon Nov 16, 2015 8:14 pm
by dbcoe
I have exactly the same problem. Version 7.2.1.600 will not start at all in Windows 10. Worked just fine in Windows 7 (Haven't tried Version 8 yet). I have initiated a troubleshooting request to Steinberg Support. I'll re-post if I hear back from Steinberg with a solution.

Re: Elements 7 not working in Win 10

Posted: Mon Oct 30, 2017 5:32 pm
by papri
Is there any solution from Steinberg? I have the same problem.

Re: Elements 7 not working in Win 10

Posted: Tue Oct 31, 2017 1:27 pm
by PG
Try running in a compatibility mode maybe. WaveLab 7 was created while Windows 10 did no exist.

Re: Elements 7 not working in Win 10

Posted: Tue Oct 31, 2017 1:30 pm
by Romantique Tp
Wavelab 9.5 is much better than 7. You should definitely upgrade if you can afford it.

Re: Elements 7 not working in Win 10

Posted: Wed Nov 01, 2017 7:11 pm
by bob99
papri wrote:
Mon Oct 30, 2017 5:32 pm
Is there any solution from Steinberg? I have the same problem.
Try the latest installer and Win 8 compatibility patch, described in the posts at the bottom of this page:

For Wavelab 7 pro:
viewtopic.php?f=47&t=120245&p=653106#p653106

The same for Wavelab 7 elements:
https://www.steinberg.net/index.php?id= ... ents_7&L=1

It worked to fix it on Win 10 here.