No Recognition of UR44C Morphing Channel Strip in Cubase Pro 8

This section is about Steinberg's UR-C audio interfaces product range
Post Reply
logfather
New Member
Posts: 7
Joined: Tue May 19, 2015 11:47 pm
Contact:

No Recognition of UR44C Morphing Channel Strip in Cubase Pro 8

Post by logfather »

Hello everyone... I wonder if anybody has experienced this same problem? i have the latest version of Cubase Pro 8 installed and all the latest drivers for the UR44C.
The unit itself seems to work OK and the URC software also seems OK although I have not had a long time to judge how good it is.

However, whether I open an existing project or a new one, the UR44C morphing channel strip does not show in the mixer. When opening a brand new project I see the space where the channel strip should be in the mixer with the familiar exclamation marks beside but no channel strip.

I have tried copying various UR44C .dll files into the VST plugins folder but this has made no difference.

I have to say that I sometimes feel that Steinberg don't always do due diligence in making sure their stuff works properly before release and I suspect this is another classic case but I would be delighted to be proved wrong of course. I have submitted a ticket but so far no reply.

If you can help or have experienced the same thing it would be good to hear from you.

Cubase Pro 8.0.40 64 bit
Windows 7 Pro 64bit
ASUS Z97-Pro
i7
32 gb RAM

Post Reply

Return to “Steinberg UR-C Series”

Who is online

Users browsing this forum: No registered users and 1 guest