Page 1 of 1

UR22C iPhone iOS 13.5 / USB blinking / not recognised

Posted: Tue May 26, 2020 3:22 pm
by jaimechr
Hi,

I just bought the UR 22C, and I was really looking forward to be able and use it for live streaming, as it is usually promoted on your communication assets : it is simple, you connect it, you power it, and there it is, here https://www.facebook.com/Steinberg/vide ... 301009984/.

Here's what i am using:
  • iOS 13.5 on an iPhone X
  • to power the interface I'm using an usb to wall port with standard 5V DC
  • to connect to the iphone, I am using Apple's USB C to Lighting cable

On the interface, I am just seeing the USB light blink, without ever going solid; as well, trying to use the dspMixFx UR-C, it just display Demo mode, and no sign of the interface being recognised whatsoever.

I have already tried the following:
  • updating firmware --> it is all up to date
  • updating iphone --> it's all up to date
  • restarting the iphone with the interface connected
  • switching on/off the interface with the iPhone connected
  • alternative power sources --> I tried an iPhone charger port instead
  • switching on/off phantom power when connected
  • switching on/off mono mode when connected
Please, could you give me a hand with this? It's extremely frustrating to have set the whole thing from my side without being able to use it.
As well, it's my second Steinberg interface, I previously have bought an UR MKII.

Thanks in advance,

Jaime