Framerate drops on 144Hz screen

Use this forum for an overview of issues and to report new ones.
Post Reply
MC89
New Member
Posts: 2
Joined: Fri Jun 28, 2019 2:01 pm
Contact:

Framerate drops on 144Hz screen

Post by MC89 »

I'm getting periodic framerate drops in Cubase 10 on my new 1440p 144Hz screen (applying the latest update didn't help). It's like the mouse framerate drops to about 20fps. This only occurs in Cubase, and only on my main screen. It doesn't happen on my secondary 60Hz screen which is used for the mixer, and it didn't happen even when that screen used to be the main screen. The framerate drops for a few seconds, then goes back up, then down again, and so on. Sometimes the screen flickers a bit when it dips. Disabling the Steinberg Power Scheme makes it worse - it makes the framerate stay low almost all of the time. It doesn't seem to happen in an empty project, but the project I'm testing now is only at 10% CPU usage and under 50% RAM.

PC is an i7 8700 with 64 gigs of RAM running Windows 10. GPU is a GTX 1060. Cubase is running off a Black Caviar HDD (with some libraries running off an SSD). Main screen is an AOC AGON AG271QX which works perfectly fine outside Cubase. Switching to 60Hz doesn't fix it.

MC89
New Member
Posts: 2
Joined: Fri Jun 28, 2019 2:01 pm
Contact:

Re: Framerate drops on 144Hz screen

Post by MC89 »

OK if I disable G-Sync this doesn't occur anymore. There seems to be some issue between Cubase and G-Sync/Freesync supported monitors. Would still love to see this fixed though. Wouldn't want to keep disabling/enabling G-Sync every time I switch between Cubase and games. I might try asking AOC support about this.

cubace
Member
Posts: 868
Joined: Sat Jan 01, 2011 6:41 pm
Contact:

[CONFIRMED]Framerate drops on 144Hz screen

Post by cubace »

I think I can confirm this issue on mac as well.
When I run my Mojave (and HighSierra too) 4K60Hz the graphics is much slower than on 4K30Hz. (630 Intel, GT1030 Nvidia and RX580 AMD)
And it seems like the MCU also get a lower update frequency. So it seems that cubase do something weird. They need to look in to that since 120Hz is common this days for game pc's. It really feels sluggish even if the CPU nor GPU is on high load.

shammer
New Member
Posts: 2
Joined: Wed Apr 08, 2020 8:37 pm
Contact:

Re: Framerate drops on 144Hz screen

Post by shammer »

I would like to confirm that I expirience the same problems. The screen (Samsung G7 32") with G-sync flickers when Cubase is opened up. When G-sync is turned off, the problem stops.

It would be nice if there could be a solution where we do not have to switch G-sync on and off between different sessions.

wagonicfolding
New Member
Posts: 3
Joined: Thu Jul 16, 2020 8:02 pm
Contact:

Re: Framerate drops on 144Hz screen

Post by wagonicfolding »

There's not much point in capping the framerate if you're fluctuating between 200 and 240.

If you're fluctuating between 90 and 144, that's a huge difference which has a noticeable effect on input lag and consistency, which does screw with muscle memory.

So yeah, there is a point in capping the framerate in this case. That's the entire point of capping the framerate.

Crayven
New Member
Posts: 40
Joined: Fri Jan 03, 2014 9:07 pm

Re: Framerate drops on 144Hz screen

Post by Crayven »

Same issues here on an 27" 2560x1440 144Hz screen. It took me a while to figure out that it actually is a frame drop. First I thought that my mouse has issues. But if your monitor supports showing the actual frame rate, then you will notice massive frame drops down to 30-40 fps which makes using Cubase impossible.
So deactivating G-Sync seems the solution, but a genaral fix would be way more better.
By the way, I also recognized this issue when using HitFilm, a video editing programm. So Cubase is not the only "one" who has to fix something.
Cubase Pro 10.5, Steinberg UR22 Audio Interface, AKAI MPK249 Keyboard,
32GB RAM, i7-6700K 4x 4GHz, 2x 2TB SSD, Windows 10 64-bit

Crayven
New Member
Posts: 40
Joined: Fri Jan 03, 2014 9:07 pm

Re: Framerate drops on 144Hz screen

Post by Crayven »

For those who did not see this epic post here, please look it up, it solved the problem so that you can genarally keep G-Sync activated:

Framedrop Fix

You have to make a little adjustment in the nvidia driver settings, adding a separate rule for Cubase.

In the Nvidia Control Panel go to 3D Settings => Program Settings =>
- add Cubase as a new program
- got to "Monitor Technology" and set this to "fixed update rate" (don't know if that is the right translation, I use the german interface)
- press the "Apply" button in the bottom right corner

Done :-)
Cubase Pro 10.5, Steinberg UR22 Audio Interface, AKAI MPK249 Keyboard,
32GB RAM, i7-6700K 4x 4GHz, 2x 2TB SSD, Windows 10 64-bit

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: arieln and 2 guests