Bug: Channel mapping mismatch after 5.1 layout.

Post general topics related to Nuendo 8 here.
Post Reply
drew_cady
New Member
Posts: 6
Joined: Sun Mar 04, 2012 6:42 pm
Contact:

Bug: Channel mapping mismatch after 5.1 layout.

Post by drew_cady »

Channels 1-16 are not passing audio through Reaktor consistently.

I am inserting a Reaktor 5 or 6 VST and it seems to be having an issue within a multichannel Nuendo bus such as 7.1, 9.1, 7.1.4 and so on. This is happening in Nuendo 8 and 10. After channel 6, channels 7, 8 and 9 are skipped as well as 14. There is also some reordering.

I have verified the mapping with the multichannel Reaktor ensemble using Sound Forge and a 12 channel .wav. All channels 1-16 were correctly mapped. So I am not sure what part of the path in Nuendo is corrupting the mapping.

I am also seeing a difference with the insert routing matrix. After 7.1 the router will drop channels of the insert. With the 9.1 layout it drops the last two channels and passes them through without processing. With the 7.1.4 the last one channel is dropped so there are some inconsistencies on how Nuendo is hand shaking.
Nuendo insert routing 9.1 bug.jpg
(40.53 KiB) Not downloaded yet
Nuendo insert routing 7.1.4 bug.jpg
(41.7 KiB) Not downloaded yet
The insert input configuration in the top right of the panel is reporting a 3rd order ambisonic meaning it is Reaktor is using all 16 channels.
Nuendo insert input configuration 7.1.4.jpg
(55.16 KiB) Not downloaded yet
Can someone help me verify this? I will try and attach a Native Instruments Reaktor ensemble with 1-16 level meters and the remapping that is working for me. You can use a mono track routed to a group or output with the ensemble inserted. Then use the panner to fly it around and see what the level meters say.
I have been enjoying creating surround plugins using Reaktor but this bug has slowed me down. There is so much potential to create some really interesting mixes.

Thank you in advance for your time.

Nuendo channel layouts for 7.1, 9.1 and 7.1.4 are;
1 Left Front
2 Right Front
3 Center
4 LFE
5 Left Surround
6 RIght Surround
7 Left Side
8 Right Side
9 Top Front Left
10 Top Front Right
11 Top Rear Left
12 Top Rear Right

Reaktor is receiving
1 mapped to 1
2 mapped to 2
3 mapped to 3
4 mapped to 4
5 mapped to 5
6 mapped to 6
7 not mapped
8 not mapped
9 not mapped
10 mapped to 7
11 mapped to 8
*12 mapped to 12
13 mapped to 9
14 not mapped
15 mapped to 10
16 mapped to 11
PC Windows 10.0.18362
i7-4790k 4GHz, RAM 32gig

Hardware
RME Fireface UFX

Software
Nuendo 8.3.2, Nuendo 10 trial
NI Komplete

drew_cady
New Member
Posts: 6
Joined: Sun Mar 04, 2012 6:42 pm
Contact:

Re: Bug: Channel mapping mismatch after 5.1 layout.

Post by drew_cady »

Here is the Reaktor ensemble to use for testing.
Again thank you!

Drew Cady
Attachments
ReaktorMappingBug_R5.zip
(4.83 KiB) Downloaded 49 times
PC Windows 10.0.18362
i7-4790k 4GHz, RAM 32gig

Hardware
RME Fireface UFX

Software
Nuendo 8.3.2, Nuendo 10 trial
NI Komplete

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 3 guests