Page 1 of 1

Halion Sonic Keeps Changing My Instrument

Posted: Mon Jun 24, 2013 2:33 am
by lee45276
I've uploaded a MIDI file into cubase and Halion Sonic is playing the MIDI file. I want to change the instrument it is using though. Currently, it's using [GM 091] Pad 3 (Poly Synth). I can switch it to another instrument but as soon as I stop playback it reverts to [GM 091] Pad 3 (Poly Synth). Why is it doing this? How do I make it stop doing that?

Re: Halion Sonic Keeps Changing My Instrument

Posted: Mon Jun 24, 2013 9:56 pm
by curteye
lee45276 wrote:I've uploaded a MIDI file into cubase and Halion Sonic is playing the MIDI file. I want to change the instrument it is using though. Currently, it's using [GM 091] Pad 3 (Poly Synth). I can switch it to another instrument but as soon as I stop playback it reverts to [GM 091] Pad 3 (Poly Synth). Why is it doing this? How do I make it stop doing that?
Aloha L,

In the MIDI file (usually near the beginning) there is an inserted MIDI message (event)
called: 'Program Change', telling Halion Sonic to bring up the Poly Synth patch.

Some times there are more than one inserted along the file.

You need to find these messages and delete or modify them
to the sounds that you want HS to play.

However I do not think you can do this in HS as a stand alone app.

But

If you load the MIDI file into any version of Cubase.
you can then use the 'List Editor' feature to find
and eliminate/change these messages

HTH (hope this helps)
{'-'}

Re: Halion Sonic Keeps Changing My Instrument

Posted: Sat Jul 06, 2013 8:15 pm
by lee45276
That's it! Thanks, man!

Re: Halion Sonic Keeps Changing My Instrument

Posted: Fri Jul 10, 2020 12:24 am
by PHAS
Hello. I have this problem. Could someone give me a more current explanation? I tried to follow the guidance above and didn't even find where to access these commands on my Cubase Elements 9.

Thank's in advance.

Re: Halion Sonic Keeps Changing My Instrument

Posted: Wed Sep 16, 2020 5:39 pm
by Dave Pegler
If you are still having trouble with this here's what I did on my 10.5 pro (so I'm sorry if you don't have the things pro has):

1) Select the midi track where the instrument changes from the one you want to the default setting every time you hit the "Stop" button on the transport bar.
2) Go to "Midi" (right at the top) and select "Open List Editor"
3) Delete all the Programme Change and Controllers at the top and
4) That's it. Your selected Halion Sonic sound should remain in place now.

I hope this helps!