possible to ignore dynamics during playback?

Discussions about our next-generation scoring application, Dorico.
andrew_34
New Member
Posts: 24
Joined: Wed Aug 14, 2019 2:17 pm
Contact:

possible to ignore dynamics during playback?

Post by andrew_34 »

I typically use playback as a means of checking for mistakes when inputting existing scores, however I find that in a full orchestral context with varying dynamics, certain voices are completely drowned out by others during playback, and if you select only certain staves at once, you don't get the full harmonic picture.

For the sake of proofreading one's work, is there any way to playback with every voice treated equally in terms of volume? Or even playing everything as one channel/instrument to identify errors? I think this is what happens while using Finale's "scrubbing" feature (which would also be great to see in Dorico someday, and I know has been mentioned here many times already).

I've just upgraded to Dorico 3.0.10, if that's relevant; thanks for any suggestions.

User avatar
dankreider
Grand Senior Member
Posts: 5293
Joined: Thu Jun 28, 2018 3:45 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by dankreider »

You could try selecting everything, filter-selecting dynamics only, then toggling on Suppress Playback. Might work.
Dan Kreider
hymnworks.com
Dorico 3, Windows 10

andrew_34
New Member
Posts: 24
Joined: Wed Aug 14, 2019 2:17 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by andrew_34 »

Thanks for the suggestion – it didn't seem to make a noticeable difference, even when dynamics were selected individually (a "fff" sounded the same when played normally and when suppressed), but it was a good idea.

User avatar
pianoleo
Grand Senior Member
Posts: 7769
Joined: Wed Oct 19, 2016 11:17 am
Location: London, UK
Contact:

Re: possible to ignore dynamics during playback?

Post by pianoleo »

Playback Options > Dynamics. Try setting the dynamic curve to 0.
Pianist/accompanist/engraver/arranger
2019 Macbook Pro 16" 2.3gGHz 8-core i9, 32GB RAM,
2015 Macbook Pro 13" Retina 3.1GHz dual-core i7, 8GB RAM; running Sibelius Ultimate, Logic Pro X, Dorico Pro 3.5 etc.
& 2017 HP ZBook Studio G3 15.6” UHD quad-i7, 16GB RAM, Windows 10 Pro
Sibelius user since Sibelius 7 (Acorn, 1997), Ex-Sibelius user since Dorico 1.0

User avatar
dankreider
Grand Senior Member
Posts: 5293
Joined: Thu Jun 28, 2018 3:45 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by dankreider »

"Suppress Playback" to negate selected dynamics sure would come in handy. Feature request!
Dan Kreider
hymnworks.com
Dorico 3, Windows 10

sakasuri
Junior Member
Posts: 53
Joined: Mon Dec 31, 2018 12:03 am
Contact:

Re: possible to ignore dynamics during playback?

Post by sakasuri »

Supressing playback of dynamics actually worked for me! When I selected the dynamics and toggled suppress playback, dorico stopped sending CC data and I could automate my own dynamic curve using CC1. I was playing back from spitfire BBC SO, which uses mostly CC data to determine the dynamic level. I have set up an expression map that uses CC1 for controlling dynamics.

What was interesting was that this was the only way I could automate CC1 myself (with this expression map). If there were no dynamics, dorico would use the last dynamic level in score and my recorded dynamics would not work. But if there is an area where there are dynamics with supressed playback on, it ”clears the space” and allows me to use my recorded CC1 data

andrew_34
New Member
Posts: 24
Joined: Wed Aug 14, 2019 2:17 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by andrew_34 »

Just tried pianoleo's idea of changing the dynamic curve to 0; didn't seem to make a difference during playback.

Is there no way to redirect the output of all instruments into one channel? I'd even be happy with everything sounding as a basic GM piano if that were an option. I'm not proficient enough on the audio/midi side of things to know if this is even possible, I just remember in Finale that even disabling the Garritan instruments (and playing back with basic midi instruments) was sometimes enough to equalize the voices' relative volumes... basically I'm just trying to strip out all realism from the playback to have a more objective look at the harmonies.

User avatar
dankreider
Grand Senior Member
Posts: 5293
Joined: Thu Jun 28, 2018 3:45 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by dankreider »

Andrew, what playback template are you using? Can you try resetting it? Sounds like something’s amiss.
Dan Kreider
hymnworks.com
Dorico 3, Windows 10

andrew_34
New Member
Posts: 24
Joined: Wed Aug 14, 2019 2:17 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by andrew_34 »

Hi Dan – I don't think I ever changed playback templates (or any audio output settings for that matter)... It was set to HSSE+HSO (Pro). However, when I changed it to Silence (and applied the changes), then changed back, I definitely got a different balance for some reason after doing this (sounds a bit better), so I'm not sure what's going on there. They were originally files made in version 2, if that's relevant.

Now that I've reset the template, suppressing the dynamics does indeed make a difference (your initial suggestion worked). It gets me much closer to the balance I was looking for, so thanks for your help, but I'd still be interested in a way to hear everything in one instrument, since I find that even with dynamics suppressed, having the standard two violin sections playing in unison tends to overpower the woodwinds, etc. No fault of Dorico's, just a little more nuanced a sound than would be ideal for catching harmonic errors. I know you can alter things in the mixer, it would just be nice to not have to adjust on a case-by-case basis.

This may not be possible, but regardless, this is definitely a lot better than without the dynamics suppressed, so thanks again for that idea.

(I'll again add my vote for a "scrubbing" feature someday down the line for auditing harmonies!)

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

I've just encountered this issue, but I'm on Elements. Looks like it's going to be more difficult for me - correct? I'd love a simple way to just toggle dynamics on & off during playback.
Elements 3.5, Windows

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

I suppose I could do it with an Expression Map? I'm using external MIDI, so I could just force all the velocities to a single value, with a MIDI translator, too. Worst case is just keeping notes and entering dynamics near the end, which won't be a big problem for my small project.
Elements 3.5, Windows

User avatar
PaulWalmsley
Steinberg Employee
Posts: 2034
Joined: Tue May 17, 2016 9:24 pm
Location: Steinberg, London
Contact:

Re: possible to ignore dynamics during playback?

Post by PaulWalmsley »

If your project is currently using the Default expression map, you can make a temporary change by editing the Expression Map and editing the dynamic controller. You could either switch it to a different CC (eg pick one over 100) or use the settings to restrict the range.
Architect & Developer - Steinberg London

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

Thanks Paul. I haven't tried editing Expression Maps yet, but it sounds simple. That's good.
Elements 3.5, Windows

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

Just FYI, I was trying to solve the wrong problem. I had applied dynamics to both hands of the piano, erroneously. Now that I have applied just to one hand, I feel less need to be able to disable dynamics during playback, at least for the time being.
Elements 3.5, Windows

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

[accidental post deleted - wrong thread]
Elements 3.5, Windows

User avatar
robjohn9999
Member
Posts: 730
Joined: Tue Feb 28, 2017 7:58 pm
Location: greater NYC region
Contact:

Re: possible to ignore dynamics during playback?

Post by robjohn9999 »

sakasuri wrote:
Thu Dec 26, 2019 10:20 am
Supressing playback of dynamics actually worked for me! When I selected the dynamics and toggled suppress playback, dorico stopped sending CC data and I could automate my own dynamic curve using CC1. I was playing back from spitfire BBC SO, which uses mostly CC data to determine the dynamic level. I have set up an expression map that uses CC1 for controlling dynamics.

What was interesting was that this was the only way I could automate CC1 myself (with this expression map). If there were no dynamics, dorico would use the last dynamic level in score and my recorded dynamics would not work. But if there is an area where there are dynamics with supressed playback on, it ”clears the space” and allows me to use my recorded CC1 data
Is this is the case, I'm wondering if Dorico has (or would consider) a setting to "always" suppress the playback of notated dynamics so that it can default to whatever expression I add via CC data in Play Mode (either while recording MIDI in realtime or added after the fact with the pencil tool, etc.)?
- D.D.
2019 MacBook Pro with 64 GB ram; Apogee Ensemble 88; Mac OS Catalina 10.15.2

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

Is "suppress dynamics" supposed to work for immediate dynamics? It's not working for me, in Elements. It lets me set that property, but it's not working.
Elements 3.5, Windows

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

(I am setting "Suppress playback" for an immediate dynamic to "on", but the dynamic is still taking effect during playback)
Elements 3.5, Windows

User avatar
Daniel at Steinberg
Moderator
Posts: 17765
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: possible to ignore dynamics during playback?

Post by Daniel at Steinberg »

I find that this does indeed work as expected. Take a look, for example, at the dynamics lane in Play mode; you will see that the dynamics whose playback you have suppressed do not appear there.

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

Thanks Daniel. I am using my ears only. It is very obvious to me that the dynamic is not being ignored, in Write mode. I am using external MIDI.
Elements 3.5, Windows

User avatar
Daniel at Steinberg
Moderator
Posts: 17765
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: possible to ignore dynamics during playback?

Post by Daniel at Steinberg »

By all means please attach a contrary example.

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

Sample project attached. The ppp dynamic has the "Suppress playback" property, but it is still being honoured, using external MIDI. Thanks for looking at this.
Attachments
immediate_dynamic_not_suppressed.zip
(343.56 KiB) Downloaded 4 times
Elements 3.5, Windows

User avatar
Daniel at Steinberg
Moderator
Posts: 17765
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: possible to ignore dynamics during playback?

Post by Daniel at Steinberg »

I can't verify the playback on your MIDI device, but I can verify the playback using the built-in sounds, and the dynamic is correctly suppressed for me. And the dynamics lane in Play mode shows the dynamic remaining fff throughout. Can you export a MIDI file of your little example so we can see what velocities are being exported?

GregS
Junior Member
Posts: 89
Joined: Fri Jul 03, 2020 1:39 pm
Contact:

Re: possible to ignore dynamics during playback?

Post by GregS »

I can reproduce this using the Microsoft GS Wavetable Synth - can you try that, Daniel? It's available as a virtual MIDI device on my system. (Windows 10). If you can get that to work, that will allow you to verify a fix, assuming this is a genuine problem.
Just btw, just now, I can't get any VST instruments to work at all, but I have not yet installed the Steinberg soundset for Elements. I've had Kontakt working in the past, but now it's stopped - when I click on the "Edit Instrument" button, nothing happens, so I can't configure Kontakt. Same problem with other VSTs. Let me know if I should open a new thread for all this - I don't want to pollute this one.
Elements 3.5, Windows

User avatar
Daniel at Steinberg
Moderator
Posts: 17765
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: possible to ignore dynamics during playback?

Post by Daniel at Steinberg »

Is it possible that the GM Wavetable Synth isn't velocity-sensitive? Or that you're specifying an inappropriate MIDI controller for the playback of dynamics? I can't easily install the GS Wavetable Synth, no (for starters I don't have my own Windows computer).

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: gdball, Lillie Harris, Ulf and 20 guests