iZotope Ozone 8 (and 9) VST2 vs VST3: reporting 32-bit vs 64-bit float

All topics on WaveLab 9 and WaveLab Elements 9
Post Reply
TheAndyMac
New Member
Posts: 14
Joined: Tue Aug 04, 2015 7:59 pm
Contact:

iZotope Ozone 8 (and 9) VST2 vs VST3: reporting 32-bit vs 64-bit float

Post by TheAndyMac »

izotope Ozone 8 and Ozone 9 plugins have some "interesting" behaviours in WaveLab…

The Ozone 8 and 9 VST3 plugins are all recognised by WaveLab as being 32-bit float (whilst they are internally 64-bit float), whilst the very same VST2 plugins are being recognised (correctly) as being 64-bit float. Ozone 8 VST3 plugins crash in WaveLab, but the Ozone 9 VST3 plugins do not.

Having talked to iZotope, the internals of both is the same (i.e. they are both using 64-bit float processing) so I am confused as to what exactly is happening in WaveLab and am trying to understand which I should use and why...

* Is WaveLab mis-recognising this, and the VST3 versions will actually work fine (i.e. using 64-bit float, assuming I have selected this in WaveLab)
* Is WaveLab mis-recognising this and the VST3 versions will only be used at 32-bit float
* Is there a reason whereby the Ozone VST3 interface code may be causing this to be the case

I have noticed that quite a few other modern VST3 plugins (which I would expect would have 64-bit float processing) are also being recognised as just 32-bit float processing, and am now wondering whether this is being reported accurately - and whether it is worth switching on 64-bit float for internal processing, or just leaving at 32-bit float.

Post Reply

Return to “WaveLab Pro 9 | WaveLab Elements 9”

Who is online

Users browsing this forum: No registered users and 1 guest