No protection device connected

Use this forum for an overview of collected issues and to report new ones.
Post Reply
dougalhead
New Member
Posts: 1
Joined: Wed Mar 25, 2015 4:08 pm

No protection device connected

Post by dougalhead »

I cannot access my Cubase SX3 3.1.1 due to the following error message. Any help would be appreciated. Jayne

Application 'Cubase SX 3.x' has caused the following error:

No protection device connected.


Options:
- For troubleshooting information click <Help>.
- Connect a valid protection device and click <Retry>.
- Click <Cancel> to abort.

CJ101
New Member
Posts: 1
Joined: Thu Oct 08, 2015 4:34 am
Contact:

Re: No protection device connected

Post by CJ101 »

Jayne did you work this out? As I have the exact same problem

CLaire

Arvin
New Member
Posts: 2
Joined: Mon Dec 18, 2017 10:37 pm
Contact:

Re: No protection device connected

Post by Arvin »

I am having the same problem too. I have an older version, Cubase 4 it worked fine on windows 7 but not windows 10
Any advice would be really appreciated.
Arvin

Baus
New Member
Posts: 1
Joined: Sat Jul 04, 2020 3:44 pm
Contact:

Re: No protection device connected

Post by Baus »

Arvin wrote:
Mon Mar 02, 2020 3:57 pm
I am having the same problem too. I have an older version, Cubase 4 it worked fine on windows 7 but not windows 10
Any advice would be really appreciated.
Arvin
Hi Arvin,

I just had the same issue. Just for fun tried installing Cubase SL3. Installation worked but upon starting up Cubase said No Protection Device Connected.

I figured that the License Control Center had something to do with this.

Go ahead and download the most recent eLicense Control Center from the Steinberg website. When you have this installed and you insert the USB Dongle with your Cubase License on it it will show up in the License Control Center. You will now be able to run your version of Cubase.

Robin Bausewein.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 5 guests