Page 1 of 1

UR22C in Linux

Posted: Fri Jun 12, 2020 7:12 pm
by lhnfwrhluwqflh
Hi,

The UR22C runs plug and play on my Linux installation (manjaro, kernel 5.6.12-1).

But the dspMixFx application won't find my device in wine. Which was to be expected I guess. (https://www.steinberg.net/de/support/do ... _ur_c.html)

If you don't plan to provide the tools/drivers/dspMixFx for Linux, could you please at least open source them? People could try to make it work and provide a running Linux version of it on github, so that the DSP can be used in Linux as well. Creative also has open sourced drivers in the past (https://www.phoronix.com/scan.php?page= ... gift&num=1)

That would be really neat.

Thanks!

Power Management and the correct USB port

Posted: Mon Jun 15, 2020 5:08 pm
by lhnfwrhluwqflh
When the Interface was connected on a USB 2.0 port instead of 3.0, it produced clicking noises every few seconds. The manual says it has to run from USB 3.0 due to the power requirements.

Here is all the other, probably irrelevant, stuff that I tried while it was on the wrong port
https://stackoverflow.com/a/57327557/4417769
https://wiki.archlinux.org/index.php/Po ... utosuspend
https://logfile.ch/linux/2017/06/15/dis ... end-linux/
maybe that helps you if you get clicking noises even though it's on usb 3.0

ALSA Master volume control

Posted: Sun Aug 23, 2020 10:19 am
by lhnfwrhluwqflh
If you want to add "Master" and "Mute" alsa controls to it so that you can do

Code: Select all

amixer set Master 10-
amixer set Mute toggle
you can use this as ~/.asoundrc:

Code: Select all

pcm.ur22cVol {
    type            softvol
    slave {
        pcm         "sysdefault:CARD=UR22C"
    }
    control {
        name        Master
        card        0
    }
}

pcm.ur22cMute {
    type            softvol
    slave {
        pcm         "ur22cVol"
    }
    control {
        name        Mute
        card        0
    }
    resolution 2
}

pcm.!default {
    type            asym
    playback.pcm {
        type        plug
        slave.pcm   "ur22cMute"
    }
    capture.pcm {
        type        plug
        slave.pcm   "sysdefault:CARD=UR22C"
    }
}
You can also map the amixer commands to your multimedia keys as shortcuts somewhere in your user interface. If you are using xfce, you can run this in a console to add those shortcuts:

Code: Select all

xfconf-query --create --channel xfce4-keyboard-shortcuts --property /commands/custom/XF86AudioRaiseVolume --type string --set 'amixer set Master 8+'
xfconf-query --create --channel xfce4-keyboard-shortcuts --property /commands/custom/XF86AudioLowerVolume --type string --set 'amixer set Master 8-'
xfconf-query --create --channel xfce4-keyboard-shortcuts --property /commands/custom/XF86AudioMute --type string --set 'amixer set Mute toggle'
If you are using KDE, KMix might work for you

More info: https://alsa.opensrc.org/How_to_use_sof ... ter_volume

Or you can use this: https://github.com/sezanzeb/ALSA-Control

Sample rate problems in pulseaudio

Posted: Sun Aug 23, 2020 10:25 am
by lhnfwrhluwqflh
Playing youtube videos makes pulseaudio switch to 48000hz, which cannot be disabled in my case by configuring /etc/pulse/daemon.conf for some reason (run `pacmd list-sinks` to get sample rates). This change of the sample rate makes the interface go quiet for 2 seconds. It can be avoided with jack2 (jack works as well probably), cadence and the pulseaudio-jack bridge https://unix.stackexchange.com/a/593132/227331