Quadrafuzz and other old plugs

For users of legacy Steinberg Cubase software
Post Reply
User avatar
haloinreverse
Junior Member
Posts: 86
Joined: Sun Jan 23, 2011 12:19 am
Contact:

Quadrafuzz and other old plugs

Post by haloinreverse »

Whatever happened to Quadrafuzz, and a few other cool old plugs that used to come with Cubase? Why did they stop including them and updating them? I love Quadrafuzz, that was a cool little plugin.
Gigabyte Designare, Intel i7-9700k, 16gb of ram, Windows 10, RME MADI HDSPe, SSL Alpha Link MADI-AX, 2x UAD-2 Quad cards, 1 UAD-2 Solo, 2 Focusrite IAS 828's and many other goodies.

msy
Member
Posts: 378
Joined: Wed Dec 15, 2010 11:37 pm
Location: Sweden
Contact:

Re: Quadrafuzz and other old plugs

Post by msy »

Cubase Pro 10.5.20
HALion 6.3.1
OS: Windows 10 (1903)
Soundcard: RME Digiface USB with ADA8200 + ARC USB
DAW: AMD Ryzen 3950x | ASUS Prime x570-P | 32GB DDR4 3600MHz | Intel p660 NVMe M.2 2TB | Samsung EVO SSD 250GB SATA | Sapphire Pulse Radeon RX 5700 XT (set to PCIE 3.0 in BIOS w/drivers Adrenaline v19.11.3)
Screen: Philips 439P9H (Curved SuperWide 32:10) @ 3840x1200
Computer related hardware: 2xUAD-2 Duo PCIE, BCF2000 (MCU), Nord Wave, Eurorack via ES3/ADAT
Other DAWs: Bitwig 3.2

User avatar
haloinreverse
Junior Member
Posts: 86
Joined: Sun Jan 23, 2011 12:19 am
Contact:

Re: Quadrafuzz and other old plugs

Post by haloinreverse »

Well yeah the old version is still available. I just want to know why they ditched development of those plugins.

Chopper was another great plugin, not included anymore or kept up to date with the latest batch.

I just want to I know why they dictehd these really usefull tools, and would really like them to update them and bring them back.
Gigabyte Designare, Intel i7-9700k, 16gb of ram, Windows 10, RME MADI HDSPe, SSL Alpha Link MADI-AX, 2x UAD-2 Quad cards, 1 UAD-2 Solo, 2 Focusrite IAS 828's and many other goodies.

User avatar
GargoyleStudio
Senior Member
Posts: 1819
Joined: Thu Dec 16, 2010 2:58 pm
Contact:

Re: Quadrafuzz and other old plugs

Post by GargoyleStudio »

They have been bringing some back from the dead, and I'm hoping they bring more back. I use the ModDelay quite a bit, nothing exactly like it in the new gamut of plugins...

Mike.
[Win10x64 latest, Cb10.5 latest, MOTU PCIe, UAD2, Waves, Soundtoys, O9N, Arturia, Omnisphere]

User avatar
haloinreverse
Junior Member
Posts: 86
Joined: Sun Jan 23, 2011 12:19 am
Contact:

Re: Quadrafuzz and other old plugs

Post by haloinreverse »

GargoyleStudio wrote:They have been bringing some back from the dead, and I'm hoping they bring more back. I use the ModDelay quite a bit, nothing exactly like it in the new gamut of plugins...

Mike.
Yeah that's another plugin also the ModDelay, why did they just dump these plugins. I also liked the ModDelay plugin myself. A little consistency with plugs from version to version is all I'm asking. :D
Gigabyte Designare, Intel i7-9700k, 16gb of ram, Windows 10, RME MADI HDSPe, SSL Alpha Link MADI-AX, 2x UAD-2 Quad cards, 1 UAD-2 Solo, 2 Focusrite IAS 828's and many other goodies.

User avatar
De-Fine music
Junior Member
Posts: 154
Joined: Sun Jan 16, 2011 6:22 pm
Contact:

Re: Quadrafuzz and other old plugs

Post by De-Fine music »

It's not supported anymore...... it's a vst 2.2, Cubase 7 only supports 2.4 or higher.

msy
Member
Posts: 378
Joined: Wed Dec 15, 2010 11:37 pm
Location: Sweden
Contact:

Re: Quadrafuzz and other old plugs

Post by msy »

De-Fine music wrote:
It's not supported anymore...... it's a vst 2.2, Cubase 7 only supports 2.4 or higher.
Are you sure it is not working? I have other VST 2.2 plugins in Cubase 7 that works.
Cubase Pro 10.5.20
HALion 6.3.1
OS: Windows 10 (1903)
Soundcard: RME Digiface USB with ADA8200 + ARC USB
DAW: AMD Ryzen 3950x | ASUS Prime x570-P | 32GB DDR4 3600MHz | Intel p660 NVMe M.2 2TB | Samsung EVO SSD 250GB SATA | Sapphire Pulse Radeon RX 5700 XT (set to PCIE 3.0 in BIOS w/drivers Adrenaline v19.11.3)
Screen: Philips 439P9H (Curved SuperWide 32:10) @ 3840x1200
Computer related hardware: 2xUAD-2 Duo PCIE, BCF2000 (MCU), Nord Wave, Eurorack via ES3/ADAT
Other DAWs: Bitwig 3.2

neilwilkes
Senior Member
Posts: 1078
Joined: Thu Dec 16, 2010 11:55 am
Contact:

Re: Quadrafuzz and other old plugs

Post by neilwilkes »

msy wrote:
De-Fine music wrote:
It's not supported anymore...... it's a vst 2.2, Cubase 7 only supports 2.4 or higher.
Are you sure it is not working? I have other VST 2.2 plugins in Cubase 7 that works.
Whilst it will run, it is not recommended as the officially supported minimum is VST2.4
www.opusproductions.com
Intel E5-2687W 8-core Xeon, 32Gb RAM, Windows 7 Pro x64, RME RayDAT, UAD-2 Octo x2 & Quad x2 (fully loaded), Adam A7 x5, WK ID Console
Nuendo 1-6, Cubase 6-7, WaveLab 5-7, DTS/DD encoders, Surround Edition etc, Waves Mercury
Blu-Ray authoring, DVD authoring & high resolution audio specialists.

Detailed Specs on request


ephesis
New Member
Posts: 1
Joined: Fri Jul 10, 2020 8:29 pm
Contact:

Re: Quadrafuzz and other old plugs

Post by ephesis »

N3urol3ptic wrote:
Thu Dec 22, 2016 8:42 pm
Win Download:
ftp://ftp.steinberg.net/Download/Legacy ... raFuzz.dll

Mac Download:
ftp://ftp.steinberg.net/Download/Legacy ... raFuzz.vst

Works with Cubase 8
hey ! I'm using MacOS now and I had Quadrafuzz on my old pc. I can't find Quadrafuzz for Mac but I've seen that you have a link to downloading it but it's not working :/ can you please send a new link for Quadrafuzz for Mac (.vst) ?

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 9 guests