Cubase 6.5 [Mac OS X Lion 10.7.5 UPDATE]

For users of legacy Steinberg Cubase software
Post Reply
jackmillican
New Member
Posts: 1
Joined: Mon Jun 15, 2020 3:51 pm
Contact:

Cubase 6.5 [Mac OS X Lion 10.7.5 UPDATE]

Post by jackmillican »

Hi,

I've been using cubase 6.5 for a good number of years now on an iMac which i bought in 2011. Unfortunately i've never had any software
updates since then! Im currently on Mac OS X Lion 10.7.5 I spoke with apple who have suggested the following;
Download Mountain
Download High Sierra

I have to download mountain in order for me to get the latest mac update High Sierra.

Im using Cubase 6.5 along with a host of plugins such as omnisphere, nexus 2, stylus, trillian etc etc.

I am concerned that once i update to the latest mac software that all of my setup will not work. Has anybody had any issues updating to the latest Mac?

Would just like a bit of information before i take the leap!

Kind regards
Jack

Widowsky
New Member
Posts: 30
Joined: Wed Jan 26, 2011 1:16 pm
Location: Paris
Contact:

Re: Cubase 6.5 [Mac OS X Lion 10.7.5 UPDATE]

Post by Widowsky »

Cubase 6.5 works fine for me on High Sierra. It sometimes crashes when I access the native vst3 preset system from the plug-in windows. So I always save my work before loading or saving a preset. I had a few other random crashes, but all in all it's a good ride. I guess turning on Autosave would be the right thing to do. I don't use the plugins you're mentioning though.
Hackintosh Intel i7-8700K • RME Fireface 800 • MacBook Pro (13-inch, Early 2011) • macOS 10.13.6 High Sierra • Cubase 6.5.5 Build 176 (64-bit) • Cubase Pro 10.0.60 Build 396

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 8 guests